• Register Today It's free! This box and some ads will disappear once registered!

^^Searches ExplorerForum.com^^

Check Gage Light

Cobrakev

Member
Joined
June 14, 2005
Messages
17
Reaction score
0
City, State
Hampton, Georgia
Year, Model & Trim Level
2000 Eddie
Hi, my check gage light comes on for a few seconds the goes out. When the light comes on, the temp gage is normal as well as the oil pressure gage. No flux what so ever. Yes, the tank has gas in it, first thing i looked for. What else in the system can cause this light to come on?

Thanks
 


Join the Elite Explorers for $20 per year. Gets rid of the ads! New $5 per month "try out" option.

Elite Explorer members see no advertisements, no banner ads, no double underlined links, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create and save more private conversations, and more. Join Today. Your support is greatly appreciated.




Cobraguy

Explorer Addict
Joined
February 22, 2008
Messages
2,520
Reaction score
13
City, State
Phoenix...Greatest City on Earth
Year, Model & Trim Level
1995 EB & 1999 EB 5.0
I would need to look for the correct answer...but you should be able to do that in your owner's manual.
 




juanquy

New Member
Joined
February 15, 2009
Messages
2
Reaction score
0
City, State
FL
Year, Model & Trim Level
2001 Sport
Hey I have the same problem, but until check gage light do not turn off the oil pressure indicator is low, any ideas?
Explorer Sport 2001
 




corkey

Moderator Emeritus
Moderator Emeritus
Joined
January 3, 2008
Messages
6,015
Reaction score
48
Location
Sioux Narrows Canada
City, State
Elite Canuck,multiple ifs offender,, and musky maniac,, i wheel and i fish,,
Year, Model & Trim Level
99 xls,96 xl,91,08 Ranger




farmtruckman

Active Member
Joined
December 26, 2007
Messages
67
Reaction score
0
City, State
ellensburg, wa
Year, Model & Trim Level
'95 xlt
kobrakev,

If you figure this one out, let me know also. my 95 does the same thing, usually cycling on for so many seconds, then off. Rinse then repeat. I posted the same question a few years ago but no one knew then. The owners manual says take it to the dealer. Right.

Good luck.

FTM
 




TheJackal

Explorer Addict
Joined
August 11, 2007
Messages
1,060
Reaction score
3
City, State
Mandeville, LA
Year, Model & Trim Level
1999 Explorer XL 2WD
IIRC the Check Gauge light is controlled by the Anti-Slosh Module. Is the fuel guage working properly? Does this happen while driving or just when starting up? The light comes on for a bulb check after starting.

The one who said the light is on with the oil pressure low, that's the way the light works, you might want to check your oil pressure. It could also be the sender. What kind of oil filter do you use?
 




ranger7ltr

Explorer Addict
Joined
November 17, 2001
Messages
1,308
Reaction score
18
City, State
Great State of Texas
Year, Model & Trim Level
1999 Sport
Here is the answer to what the "Check Gage" does...

I found this in the 99 Explorer owners' manual...And I wondered what that light was turned on by as well...


Illuminates when the engine coolant temperature is high, the engine oil
pressure is low or the fuel gauge is at or near empty. The ignition must
be in the ON position for this lamp to illuminate. The lamp will also
illuminate for several seconds after the ignition is turned to the ON
position.
 




juanquy

New Member
Joined
February 15, 2009
Messages
2
Reaction score
0
City, State
FL
Year, Model & Trim Level
2001 Sport
Hey Jackal

Thats happens when I start up, but the light is on around 5 min during this period the oil pressure indicator is low, actually I remember now thats coming happened after I change the oil filter around 3 week ago, I buy one in autoparts. What kind of filter use my 01?, because always I ask to the guys in the store maybe they gave me a wrong filter. I really scared guys 5 min if enough to kill my engine.
 




briwayjones

Manual Master
Joined
December 11, 2003
Messages
4,481
Reaction score
4
Location
Maryland, USA
City, State
Eldersburg, MD
Year, Model & Trim Level
2000 Ford Explorer XLS
Thats happens when I start up, but the light is on around 5 min during this period the oil pressure indicator is low, actually I remember now thats coming happened after I change the oil filter around 3 week ago, I buy one in autoparts. What kind of filter use my 01?, because always I ask to the guys in the store maybe they gave me a wrong filter. I really scared guys 5 min if enough to kill my engine.

Most likely your Oil pressure is reading low because of a bad oil pressure sending unit or a corroded connection with it. Very common problem.
 




farmtruckman

Active Member
Joined
December 26, 2007
Messages
67
Reaction score
0
City, State
ellensburg, wa
Year, Model & Trim Level
'95 xlt
Check Gage Light Issue

the Jackel,

Where is the anti-slosh module? My "check gage" started doing the exact thing described after I ran the gas down real low (on fumes) and since then, the gage light cycles as described. My gas gauge works fine but the temperature gauge stop working years ago so I don't think that it is related to the "check gage". I never heard of the anti-slosh module and thought, maybe something went wrong when I ran the tank so low.

Thanks ahead for any help.

FTM:usa:
 




sempermech69

New Member
Joined
February 18, 2011
Messages
2
Reaction score
0
City, State
ne ohio
Year, Model & Trim Level
94,95,96,97,99 xlt eddie
the module is located in the back right upper corner of the cluster ,
 




bobflood

Elite Explorer
Joined
May 27, 2010
Messages
1,577
Reaction score
26
City, State
Powder Springs, GA
Year, Model & Trim Level
1997 Eddie Bauer V8 2WD
Hi, my check gage light comes on for a few seconds the goes out. When the light comes on, the temp gage is normal as well as the oil pressure gage. No flux what so ever. Yes, the tank has gas in it, first thing i looked for. What else in the system can cause this light to come on?

Thanks

Battery voltage guage can also turn on that light if too low (don't know about if too high).
 




Joe Dirt

Explorer Addict
Joined
October 4, 2007
Messages
13,390
Reaction score
18
Year, Model & Trim Level
07 Camry
I just hope it's fixed, as that was 2-1/2 years ago... :D
 




bobflood

Elite Explorer
Joined
May 27, 2010
Messages
1,577
Reaction score
26
City, State
Powder Springs, GA
Year, Model & Trim Level
1997 Eddie Bauer V8 2WD
I just hope it's fixed, as that was 2-1/2 years ago... :D

Yeah - might be a leetle late!!! I usually try to notice that!! Thanks Joe!!:D
 




Eb 60

New Member
Joined
August 5, 2015
Messages
6
Reaction score
0
Year, Model & Trim Level
2003 Ford Explorer 4.l
I have the same problem, with my Explorer 2003 4.0L. Check gauge light comes ON, the oil pressure indicator is low, at idle speed <1000 rpm, and Temperature gauge above middle. but when I hit the gas the light went out and the gauge went back up ....
any ideas????
 




1998Exp

Explorer Addict
Joined
December 5, 2010
Messages
1,235
Reaction score
127
City, State
Seattle WA
Year, Model & Trim Level
98 Limited V8 AWD
Wrong forum - this is for 2nd Gen Explorers; yours is 3rd.
In general, low pressure indicator on means one of two things: 1) Bad sender 2) Low oil pressure. Hopefully it's the first option; because the second may indicate a worn engine. The "proper" way to diagnose is to remove the sender and attach a pressure gauge, to see what the real pressure is. The "quick and dirty" way is to replace the sender and hope for the best. You choose.
 




Eb 60

New Member
Joined
August 5, 2015
Messages
6
Reaction score
0
Year, Model & Trim Level
2003 Ford Explorer 4.l
Wrong forum - this is for 2nd Gen Explorers; yours is 3rd.
In general, low pressure indicator on means one of two things: 1) Bad sender 2) Low oil pressure. Hopefully it's the first option; because the second may indicate a worn engine. The "proper" way to diagnose is to remove the sender and attach a pressure gauge, to see what the real pressure is. The "quick and dirty" way is to replace the sender and hope for the best. You choose.
Thanx, where is this sender location?
 




1998Exp

Explorer Addict
Joined
December 5, 2010
Messages
1,235
Reaction score
127
City, State
Seattle WA
Year, Model & Trim Level
98 Limited V8 AWD
Not familiar with the 4.0 SOHC engine or your 3rd gen Ex, so can't tell you the exact location or how to get there. It's usually screwed in the engine block near the oil filter. Look for a round part, about 1" diameter, with a single wire attached. Any auto parts store will have them. They are knurled on the outside, and may require a special wrench.
 




koda2000

Explorer Addict
Joined
September 2, 2011
Messages
13,841
Reaction score
1,471
Year, Model & Trim Level
x
I believe you'll find the oil pressure switch located behind the power steering pump. Go through the driver's side inner fender. I don't think it requires a special wrench, just a deep socket of the appro size. The hard part is getting the wire to disconnect from the switch.
 


Join the Elite Explorers for $20 per year. Gets rid of the ads! New $5 per month "try out" option.

Elite Explorer members see no advertisements, no banner ads, no double underlined links, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create and save more private conversations, and more. Join Today. Your support is greatly appreciated.




Eb 60

New Member
Joined
August 5, 2015
Messages
6
Reaction score
0
Year, Model & Trim Level
2003 Ford Explorer 4.l
Not familiar with the 4.0 SOHC engine or your 3rd gen Ex, so can't tell you the exact location or how to get there. It's usually screwed in the engine block near the oil filter. Look for a round part, about 1" diameter, with a single wire attached. Any auto parts store will have them. They are knurled on the outside, and may require a special wrench.
Thanx ...
 




Top