My BII Project | Page 14 | Ford Explorer - Ford Ranger Forums - Serious Explorations
  • Register Today It's free!

My BII Project

410Fortune

Truck Season!!
Staff member
Moderator
Joined
August 3, 2000
Messages
28,682
Reaction score
4,994
City, State
NORTH IDAHO, 7B
Year, Model & Trim Level
B2 "Slightly" Modified
Callsign
FOURTEN
Dude??? We talked about the fuel pump and EEC relay before I thought you replaced them? hahahaha
fingers crossed
 



Join the Elite Explorers for $20 each year.
Elite Explorer members see no advertisements, no banner ads, no double underlined links,.
Add an avatar, upload photo attachments, and more!
.





SBJ420

Well-Known Member
Joined
June 12, 2006
Messages
443
Reaction score
0
City, State
Windsor NS
Year, Model & Trim Level
95 XLT
ahahaha noooooooo I changed the Starter relay, Ingnition switch, EEC Computer, a EEC Fuse. But I will get this thing tomorrow, stick it in, well see what happens.!
 






410Fortune

Truck Season!!
Staff member
Moderator
Joined
August 3, 2000
Messages
28,682
Reaction score
4,994
City, State
NORTH IDAHO, 7B
Year, Model & Trim Level
B2 "Slightly" Modified
Callsign
FOURTEN
man the fuel pump relay was the first thing that was recommended for your issues
there are 3 relays under your fuse box, fuel, computer and heater/ ac wo
 






SBJ420

Well-Known Member
Joined
June 12, 2006
Messages
443
Reaction score
0
City, State
Windsor NS
Year, Model & Trim Level
95 XLT
Oh man you are right!!! Sorry this is my first time dealing with any elcetrical issues at all. I found the relays that you where talking about, found out that they are clicking. The one that clicks the most is the black and gray one, E3TB13A025A2A - Not sure what one this is, but I got a new one, $50 at ford or $20 at a local parts store.... HAHA! But it did not fix my problem. So I was looking at the other relays aswell. After trying to start the truck for a few min I grabbed this brown / Black one E3AFA2A646B2A and it was hot, so I took it out and took a look at it and noticed it was nasty! So I will replace this one, if this does nothing than I will buy a code reader... Now if I end up getting a code reader... I changed my computer, will this be a problem? Here are some pics of what I am looking at. Any idea what relay is for what?
 






410Fortune

Truck Season!!
Staff member
Moderator
Joined
August 3, 2000
Messages
28,682
Reaction score
4,994
City, State
NORTH IDAHO, 7B
Year, Model & Trim Level
B2 "Slightly" Modified
Callsign
FOURTEN
FUEL, PCM POWER, HEATER BLOWER

Those are what the 3 relays are for.
 






SBJ420

Well-Known Member
Joined
June 12, 2006
Messages
443
Reaction score
0
City, State
Windsor NS
Year, Model & Trim Level
95 XLT
so does this sound about right?

Black / Gray = Fuel
Black / Green = Heater Blower
Black / Brown = PCM Power
 






410Fortune

Truck Season!!
Staff member
Moderator
Joined
August 3, 2000
Messages
28,682
Reaction score
4,994
City, State
NORTH IDAHO, 7B
Year, Model & Trim Level
B2 "Slightly" Modified
Callsign
FOURTEN
42309637_160.gif


green is fuel
brown is PCM
black is AC WOT/heater
 












SBJ420

Well-Known Member
Joined
June 12, 2006
Messages
443
Reaction score
0
City, State
Windsor NS
Year, Model & Trim Level
95 XLT
no the truck does not run at all. I will replace these two fuel and PCM relays. Than get a code reader if the relays to not fix the problem.
Some times it almost starts. Like it will kick in for just a second but than not start...
 












SBJ420

Well-Known Member
Joined
June 12, 2006
Messages
443
Reaction score
0
City, State
Windsor NS
Year, Model & Trim Level
95 XLT
Yeah I seen that there when I first got the truck, I couldent find what it is actually for. What is it? It has never been hooked up.... When I got the truck it had a few wires that were not connected, I was told they were all for old lights, CB's, and AMP / Stereo stuff etc....

Now the one I am talking about is going to the NEG. Batt and it looks like it has a inline fuse on it....
 












BRONCO 2

Active Member
Joined
September 24, 2006
Messages
72
Reaction score
0
City, State
S.Newbury NH
Year, Model & Trim Level
(2) 90 B2's and a 88
you havent had this runnin since 08-15-2006????? WTF and 14 pages. Put some gas in a squirt bottle,squirt it in the intake and turn the key.If it runs then its a fuel related problem.Never mind buying this and that,you gotta see if it runs first
 






SBJ420

Well-Known Member
Joined
June 12, 2006
Messages
443
Reaction score
0
City, State
Windsor NS
Year, Model & Trim Level
95 XLT
you havent had this runnin since 08-15-2006????? WTF and 14 pages. Put some gas in a squirt bottle,squirt it in the intake and turn the key.If it runs then its a fuel related problem.Never mind buying this and that,you gotta see if it runs first


hahahaha wellllllllllllllllllllllllllllllllllllllllllllllllll it died about 13 days ago so that would make it 1/10/2007............ It ran fine for about a 1/2 a year with no problems!!! I can see I am starting to drive people crazy :confused:
ill get it figured out :thumbdwn: Thanks for the help
 






410Fortune

Truck Season!!
Staff member
Moderator
Joined
August 3, 2000
Messages
28,682
Reaction score
4,994
City, State
NORTH IDAHO, 7B
Year, Model & Trim Level
B2 "Slightly" Modified
Callsign
FOURTEN
the crazy thing is we have been over the battery wiring, relays, the inertia switch, how the computer turns on the fuel pump, all of this.
And now he goes back and says where is my fuel pump relay, and I am like thats the first thing we discussed and you said it was fine....

Sometimes you have to take notes in order to diagnose the problem

My fingers are crossed, again....
 






SBJ420

Well-Known Member
Joined
June 12, 2006
Messages
443
Reaction score
0
City, State
Windsor NS
Year, Model & Trim Level
95 XLT
Well keep in mind I have NEVER done any electrical work in my life....
With that said, when you told me anything about a relay, I always thought that there was ONE relay, this being the starter relay, I thought that all the prongs on this went to, fuel pump, computer, starter.... No idea that it went to JUST the starter.... I also had no idea there was a fuel pump ground that went to the batt. Yes I checked the batt. and made sure all connections were fine.

So when you asked if I replaced the EEC, FUEL, relay I thought that I DID!
I am doing all of this with no help, other than the info I get from the internet, I have no one that can point and tell me what this does or where that goes. I am trying. But I am not here to waste your guys time or take up your guys web space. Everything I need to know is in my Haynes and Ill stick to that.
 






410Fortune

Truck Season!!
Staff member
Moderator
Joined
August 3, 2000
Messages
28,682
Reaction score
4,994
City, State
NORTH IDAHO, 7B
Year, Model & Trim Level
B2 "Slightly" Modified
Callsign
FOURTEN
I understand the confusion man, its easily made when chatting on line.
Pictures rule and have helped to sort out many issues like these over the years....some guys even go buy a disposable camera, then have the film developed at Walgreens or the grpcery store where you can have them put on a CD or emailed to you jsut so we could all get on the same page.

What counts is that you found the relays now, I got $$$ that says there is your issue, but always be sure to check the wiring around them as well, a 88 BII is OLD these days and wiring gets old too
Hell I just fixed a 98 Prelude, my friends car was cutting out on her, it would just die, everything looked brand new 100%, all connections were good, except there was a bit of corrossion inside one of her battery clamp on terminals, cleaned it up, car has been fixed ever since.....so its not always easy to find no matter how much you look or know what to look for.
 






SBJ420

Well-Known Member
Joined
June 12, 2006
Messages
443
Reaction score
0
City, State
Windsor NS
Year, Model & Trim Level
95 XLT
alright I got it to start with no problems now. First it ran sooooooooooooooooo bad, missing, blowing black smoke like crazy! So I took the new computer I just put in and put my old one back in, and it works alot better now. No engine light or anything. But now it still doesent run so good, when I crank the wheel and press the break it dies out, just feels weak as hell. And it sputters all the way down the street. But no engine light at all.
Any idea why its runnung like poop? I did put new plugs in, but think maybe when it was running with the other computer it could have fouled them?

Thanks agian for the help!!! It was one of those relays like you said way back! I now have 3 new relays tho. I got it moved to the side of the house now so I can start my D35 swap in
 






SBJ420

Well-Known Member
Joined
June 12, 2006
Messages
443
Reaction score
0
City, State
Windsor NS
Year, Model & Trim Level
95 XLT
Okay here are some pics :) I got a new MSD Coil today as well. But my question is, what is this plug for? I cannot find any place for it. Does not look like I unpluged it. There is two plugs, one gray, small one and one large black one.
DSCF4732.jpg

DSCF4733.jpg

DSCF4735.jpg


and my new coil :)
DSCF4737.jpg
 



Join the Elite Explorers for $20 each year.
Elite Explorer members see no advertisements, no banner ads, no double underlined links,.
Add an avatar, upload photo attachments, and more!
.





410Fortune

Truck Season!!
Staff member
Moderator
Joined
August 3, 2000
Messages
28,682
Reaction score
4,994
City, State
NORTH IDAHO, 7B
Year, Model & Trim Level
B2 "Slightly" Modified
Callsign
FOURTEN
thats your diagnostics port for pulling computer codes :)

it does not go anywhere

Okay so now it is running, you can do some testing.
Did you ever get the timing set properly and the distributor installed correctly?

When was the last time it ran like factory?

That was this truck right? Just making sure I am not confusing threads
 






Top