Passenger side mirror | Ford Explorer - Ford Ranger Forums - Serious Explorations
  • Register Today It's free!

Passenger side mirror

Lagos

New Member
Joined
March 4, 2014
Messages
1
Reaction score
0
Year, Model & Trim Level
2004 explorer xlt
The passenger side mirror on my 04 explorer will only adjust up or down not in or out. Can this be repaired or do I need to replace the mirror or the power cord? Thanks
 






BigRondo

USMC 1371
Staff member
Moderator
Elite Explorer
Joined
February 15, 2010
Messages
7,845
Reaction score
17
City, State
Charlestown, RI
Year, Model & Trim Level
2014 Escape SE
Welcome aboard!! :salute:

I have moved your thread to the Stock 2002 - 2005 Explorers Sub Forum to get better exposure.

I had similar electrical issues with my '02 XLT. The dome lights would stay on until the battery saver feature turned them off, the accessory delay wasn't working, the driver side puddle light didn't work, the keypad on the door would set off the alarm when I pressed it, the door ajar light would flash and beep at highway speeds, the radio would shut off as soon as I turned the key off, the alarm would beep twice when I armed it. Recently all 4 windows stopped working. Most recently the driver door lock actuator stopped working.

A lot of electrical issues can be traced back to broken/damaged wire(s) in the boot between the body and the driver's door. I found 3 broken wires and repaired them. The thin black ground wire was broken and after repairing it all was back to normal. When the windows stopped working, I repaired the thick black ground wire and the windows now work like a champ. I had to repair the pink/black wire to fix the driver door lock actuator.

Here is the thread for removing the door panel: http://www.explorerforum.com/forums//showthread.php?t=303524

Here is a great thread for checking for broken/damaged wires, thanks to synyster for this awesome write-up: http://www.explorerforum.com/forums//showthread.php?t=270081

Unfortunately the pictures are no longer available in the above thread. IIRC, I believe I unwrapped the wires enough to gain access. When I have gone searching in there I had an idea of what wire I was looking for. I located the the wire I was looking for and gently tugged on that wire on the door side. The wire was pulled toward me and out of the harness. I then went inside the vehicle and gently tugged on the the wire I was looking for and was able to pull it inside the vehicle. I then spliced a length of wire to the 2 ends, completing the circuit. I then gently pulled the excess into the door.

Be sure to take your time when looking for broken/damaged wire(s). Check all the wires for breaks/damage. When you think you're done looking, look again, and again, and again. A bright flashlight can be very helpful.

-----------------------------------------------------------------------------------------------------------------------------------

I can post some info from my shop manual tomorrow night after work.

Good luck getting it sorted. :thumbsup:

Please keep us posted as feedback helps others reading this post looking for a fix to the same or similar issue!
 






ROBinGa

Well-Known Member
Joined
February 16, 2014
Messages
346
Reaction score
30
City, State
Ga
Year, Model & Trim Level
2003 Explorer XLT 4x4 4.6
My 03 XLT was doing this exact same thing. I took out the switch and could tell by testing it with multimeter that it had failed. I got lucky and found one on eBay for about $9 that was used. I plugged it in place of the original and walla all mirror motions worked again. Maybe this is what's wrong with yours too.
 






jeff4912

Active Member
Joined
July 27, 2006
Messages
94
Reaction score
1
City, State
Seattle, Wa
Year, Model & Trim Level
2003 Ford Explorer 4WD
My 03 XLT was doing this exact same thing. I took out the switch and could tell by testing it with multimeter that it had failed. I got lucky and found one on eBay for about $9 that was used. I plugged it in place of the original and walla all mirror motions worked again. Maybe this is what's wrong with yours too.

Ditto for me too. New switch fixed it. Got it on ebay.
 






Top