Random misfire p0300 p0302 | Ford Explorer - Ford Ranger Forums - Serious Explorations
  • Register Today It's free!

Europin

New Member
Joined
December 17, 2017
Messages
2
Reaction score
0
City, State
Baltimore MD
Year, Model & Trim Level
02 Ford Explorer 4.0 XLS
2002 Ford Explorer with 150k miles. Have done maintenance mostly myself. For last 2 yrs the check engine light has been on and would occasionally go off. Code check said was an o2 sensor so I blew it off. As of a month ago I noticed lack of power while driving. Pedal down to floor and car wouldn’t budge, slow off the start etc. When stopped at stop light brake pressed car throttle seemed to increase and decrease as if I pressed the gas when I didnt. Got code checked again this time p0300 cylinder 2 misfire and (another code) random misfire showed up.
I changed the plugs - nothing changed
I changed the wires - nothing changed
I changed the ignition coil pack - nothing changed
Any help with this issue would be a great HELP.
Thanks
 






Fordfan03

Member
Joined
March 19, 2017
Messages
10
Reaction score
0
City, State
NC
Year, Model & Trim Level
2003 explorer xlt
sounds like you might have a clogged Catalytic converter(s). have you check back pressure yet?
 






verno316

Member
Joined
February 2, 2015
Messages
11
Reaction score
0
City, State
oshawa
Year, Model & Trim Level
02 explorer
I had a very similar problem and I will second FordFan's post. Check the Cat's we just replaced all of ours after the same symptoms.
 






Top