• Register Today It's free! This box and some ads will disappear once registered!

A "how to" to not have problems with MFT ?


Daheim111

Active Member
Joined
February 16, 2017
Messages
187
Reaction score
7
City, State
Germany / Thüringen
Year, Model & Trim Level
2013 Sport
Sometimes I got and get problems with nav ("no sd card detected" or in the central display "fault with navigation / see display" or so). Tried to start the car only with remote start, then open the door, start with button (and first after press the button comes Sync/MFT on !): NO more problems occurs ! My first opinion was: battery, measured 11.9 V, ok new battery (old: 3 years old OEM 65 amh/hrs, new one a little bit more from Exide) !
After this: same problem / no problem when use remote start ! To many elements with power consumption at the same time (when start with button it means not with remote start) ?
Anyone with the same phenomenon ?
 


Join the Elite Explorers for $20 per year. Gets rid of the ads! New $5 per month "try out" option.

Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see no advertisements, no banner ads, no double underlined links, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create and save more private Conversations, and more. Join Today. Your support is greatly appreciated.




peterk9

Staff member
Moderator
Elite Explorer
Joined
December 28, 2010
Messages
28,386
Reaction score
1,737
City, State
Russell, Ontario (Ottawa area)
Year, Model & Trim Level
2020 Aviator Reserve
Callsign
VE3
The 'No S/D card detected' and navigation fault messages should have nothing to do with the vehicle's battery. They are likely symptoms of some other issue.
Have you tried shutting the radio off before starting the vehicle and then turning it ON after you have started it to see if you get the same errors?

Peter
 




Jon M

Elite Explorer
Joined
January 12, 2017
Messages
732
Reaction score
135
City, State
Mount Pleasant, SC
Year, Model & Trim Level
2015 Explorer XLT
Is the MFT software up to date?
 




Daheim111

Active Member
Joined
February 16, 2017
Messages
187
Reaction score
7
City, State
Germany / Thüringen
Year, Model & Trim Level
2013 Sport
Last edited:




peterk9

Staff member
Moderator
Elite Explorer
Joined
December 28, 2010
Messages
28,386
Reaction score
1,737
City, State
Russell, Ontario (Ottawa area)
Year, Model & Trim Level
2020 Aviator Reserve
Callsign
VE3
3.6 and Ford owners says also "up to date"...
@peterk9: turn off the radio is the same I thought so (items with too many power consumption at the same time)...and when I use remote start, exactly that is the matter...radio off until I press the start button !?

BTW: Thanks, @peterk9 ! Competence...

BTW no. 2: What do you think about this:

http://www.explorerforum.com/forums/index.php?threads/mft-update-v3-10.458981/page-2#post-3620243

From Russia ??

Gert
Version 3.6 is not the latest one in North America. V3.10 is and it replaced V3.8. The Ford Owner site information is unfortunately not reliable any more. The power consumption should not be the problem since no one else is reporting the same issue that you have. Something else must be wrong. Here is a post with the V3.10 update link but I don't know if it is also for 'export' Explorers. http://www.explorerforum.com/forums/index.php?threads/mft-update-v3-10.458981/page-2#post-3620227
 
Last edited:




Daheim111

Active Member
Joined
February 16, 2017
Messages
187
Reaction score
7
City, State
Germany / Thüringen
Year, Model & Trim Level
2013 Sport
@peterk9, found this earlier, but what do you think about it ("comes from Russia") / can I trust on it ? If you say YES, I try it today ! Already loaded it on a stick...
 




peterk9

Staff member
Moderator
Elite Explorer
Joined
December 28, 2010
Messages
28,386
Reaction score
1,737
City, State
Russell, Ontario (Ottawa area)
Year, Model & Trim Level
2020 Aviator Reserve
Callsign
VE3
@peterk9, found this earlier, but what do you think about it ("comes from Russia") / can I trust on it ? If you say YES, I try it today ! Already loaded it on a stick...
Unfortunately I have no information on that download so I'm not in a position to comment on it one way or the other. As a member mentioned in the other thread, that software update was for the North American market so I have no idea if it is compatible with 'export' models. As always, use at your own risk!

Peter
 




Daheim111

Active Member
Joined
February 16, 2017
Messages
187
Reaction score
7
City, State
Germany / Thüringen
Year, Model & Trim Level
2013 Sport
Thanks to Benk016 and peterk9 !!!
Risky to do it her in Germany...no help...german dealer said to me that they can not help anyway...but I installed 3.10 / installation works great / about an half hour and finally comes 3.10 on my display ! Now I have to check next days / hope that my problem is solved now !
 




Top