Need some help | Ford Explorer - Ford Ranger Forums - Serious Explorations

  • Register Today It's free! This box and some ads will disappear once registered!

KillerKidd42

Active Member
Joined
September 24, 2012
Messages
60
Reaction score
0
City, State
Salem, Va
Year, Model & Trim Level
97 ford explorer sport
I have a explorer sport 97 sohc with 160000 miles. I'm experiencing a rough idle and is throwing two cel codes p0153 and p1504 I have replaced both tge iac and o2 sensor. I have checked for vaccum leaks and have found none. Cleaned maf, throttle body, new iac, tps. I have ran out of ideas. Any advice would be greatly appreciated.
 
<

Join the Elite Explorers $20 Gets rid of the ads!

Elite Explorer members see no advertisements, no banner ads, no double underlined links, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create and save more private conversations, and more. Join Today. Your support is greatly appreciated.




Jstcruz

Well-Known Member
Joined
July 24, 2010
Messages
795
Reaction score
2
City, State
Deltona, FL
Year, Model & Trim Level
97 Ex XLT & 84 Ranger
I was having issues untill I broke down and replaced the upper intake gaskets. Its like a new truck since that
 
<



KillerKidd42

Active Member
Joined
September 24, 2012
Messages
60
Reaction score
0
City, State
Salem, Va
Year, Model & Trim Level
97 ford explorer sport
Thanks for tje quick reply did you have same issue
 
<



Jstcruz

Well-Known Member
Joined
July 24, 2010
Messages
795
Reaction score
2
City, State
Deltona, FL
Year, Model & Trim Level
97 Ex XLT & 84 Ranger
I had a high idel, cel light - dont remember the codes, but I replaced O2's, IAC, cleaned the MAF, Checked over everything... Nothing. After the Intake rebuild it runs better than it ever has under my ownership.
 
<



KillerKidd42

Active Member
Joined
September 24, 2012
Messages
60
Reaction score
0
City, State
Salem, Va
Year, Model & Trim Level
97 ford explorer sport
Did it hesitate when you applied gas
 
<



Jstcruz

Well-Known Member
Joined
July 24, 2010
Messages
795
Reaction score
2
City, State
Deltona, FL
Year, Model & Trim Level
97 Ex XLT & 84 Ranger
It ran OK other than it idelsed high. But in searching for my fix, I read that several others acted similar to yours.
 
<



koda2000

Explorer Addict
Joined
September 2, 2011
Messages
13,852
Reaction score
1,502
Year, Model & Trim Level
x
intake manifold gaskets/o-rings. do upper and lowers while you're at it. super common problem with these engines. and i'd also clean your MAF sensor.
 
<



KillerKidd42

Active Member
Joined
September 24, 2012
Messages
60
Reaction score
0
City, State
Salem, Va
Year, Model & Trim Level
97 ford explorer sport
Picked up some intake gaskets today on my lunch break. This will be a soon to do job maybe in morning. Hope this fixes the problem.

Koda I have cleaned the maf multiple times I have unplugged it and ran in safe mode and ut ran better. If this doesnt fix it.,a new maf will be my next purchase. Wise man once said try fixing the cheapest solutions first
 
<



Jstcruz

Well-Known Member
Joined
July 24, 2010
Messages
795
Reaction score
2
City, State
Deltona, FL
Year, Model & Trim Level
97 Ex XLT & 84 Ranger
I just did my intake gaskets a few days ago with my friends help. It only took a couple hours. If you need help with it this is the place to get it
 
<



KillerKidd42

Active Member
Joined
September 24, 2012
Messages
60
Reaction score
0
City, State
Salem, Va
Year, Model & Trim Level
97 ford explorer sport
Ok so I replaced tge gaskets yesterday. And no change. Still having rough idle only in gear thoigh neutral and park it idles fine
 
<



2000StreetRod

Staff member
Moderator
Joined
May 26, 2009
Messages
10,598
Reaction score
276
City, State
Greenville, SC
Year, Model & Trim Level
00 Sport FI, 03 Ltd V8
Persistent P1504?

P0153 02 Sensor Circuit Slow Response (Bank 2 Sensor 1)
P1504 Intake Air Control circuit malfunction

If you clear the DTCs does the P1504 come back or was it just because you disconnected the IAC valve?

Does disconnecting the electrical connection to the IAC valve make a difference in the idle?
 
<



KillerKidd42

Active Member
Joined
September 24, 2012
Messages
60
Reaction score
0
City, State
Salem, Va
Year, Model & Trim Level
97 ford explorer sport
It idles the same. When I clear the codes I can go for a week maybe two before the code reapears it ran better when my maf was unplugged and whats causeing the o2 sensor I beleive its the cat may be clogged
 
<



Jstcruz

Well-Known Member
Joined
July 24, 2010
Messages
795
Reaction score
2
City, State
Deltona, FL
Year, Model & Trim Level
97 Ex XLT & 84 Ranger
It idles the same. When I clear the codes I can go for a week maybe two before the code reapears it ran better when my maf was unplugged and whats causeing the o2 sensor I beleive its the cat may be clogged

If it idels the same with the IAC you probably still have an air leak in the intake. maybe down as far as the intake manifold?
 
<



KillerKidd42

Active Member
Joined
September 24, 2012
Messages
60
Reaction score
0
City, State
Salem, Va
Year, Model & Trim Level
97 ford explorer sport
When I get some time imma remove all the vaccum lines and check each one individualy
 
<



Jstcruz

Well-Known Member
Joined
July 24, 2010
Messages
795
Reaction score
2
City, State
Deltona, FL
Year, Model & Trim Level
97 Ex XLT & 84 Ranger
I was told to start my engine and spray something like carb cleaner - other similar things work - and just spray into areas where a vacume leak could occur. If the idel changes, thats where your leak is.
 
<



KillerKidd42

Active Member
Joined
September 24, 2012
Messages
60
Reaction score
0
City, State
Salem, Va
Year, Model & Trim Level
97 ford explorer sport
Ive done that and have not had a problem my idle never changed but idk may try in morning or hell might go do now im bored any way
 
<



KillerKidd42

Active Member
Joined
September 24, 2012
Messages
60
Reaction score
0
City, State
Salem, Va
Year, Model & Trim Level
97 ford explorer sport
Ok went thru a can an a half of carb cleaner buddy of mine said carb cleaner was the best he worked at berglund for 14 years and still did not find a leak so this weekend imma be taking off the intake again checking for some cracks or dry rots in my lines
 
<



Jstcruz

Well-Known Member
Joined
July 24, 2010
Messages
795
Reaction score
2
City, State
Deltona, FL
Year, Model & Trim Level
97 Ex XLT & 84 Ranger
Ok went thru a can an a half of carb cleaner buddy of mine said carb cleaner was the best he worked at berglund for 14 years and still did not find a leak so this weekend imma be taking off the intake again checking for some cracks or dry rots in my lines

Take the fuel rail off and clean it real good too. Replace those gasgets and the EGR tube O-ring. Be carefull not to lose the O-rings on the injecters. (If you havent done all this already)
 
<



Top