3800 M90 Build | Page 36 | Ford Explorer - Ford Ranger Forums - Serious Explorations

  • Register Today It's free! This box and some ads will disappear once registered!

3800 M90 Build

Ok the cats out the bag!!im going supercharged .its a 3800 gm m90.i need lots of help as im a nos guy.for starters my list of mods is in my signature.the guy im buying it from ran it on a stock tuned motor at 3psi.first question is what is the "safe" limit to run boost at?i know it is not ideal but i have a wide band O2 and will be doing tuning very soon.i also will be trying to have my company make a new lower intake mounting bracket on the cnc machine and have it taped for nos/water meth injectors/spray bars.i will also be getting a p+p unit from 3800 performance and stepping down on the pulley to try and run 8-10psi.what size injectors should i run for that?which fuel pump should i run?any suggestions on tuning?i was going to go mega squirt but i see sct has a new chip out,any suggestions?


DONE

ported and polished gm 3800 gen 2 m90
Water to air intercooled
port matched 76mm inlet and intake tube
mustang 75mm race tb
90mm maf
36lb injectors
255 fuel pump
sct 5bank dyno tuned
2.7" pulley 10lbs of boost!!;)
2012-06-09201057.jpg


2012-06-09201139-1.jpg


2012-06-09201207.jpg


dyno run,these was the last two pulls with the 2.7 and the alternator was bad.turn your volume down!!

and a 3.25 pull and think my rev is still set to 5000 in this one
 


Join the Elite Explorers for $20 per year. Gets rid of the ads! New $5 per month "try out" option.

Elite Explorer members see no advertisements, no banner ads, no double underlined links, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create and save more private conversations, and more. Join Today. Your support is greatly appreciated.




jd4242

Elite Explorer
Joined
October 15, 2008
Messages
10,788
Reaction score
286
City, State
va beach
Year, Model & Trim Level
92explorer&94 ranger
Love the sniff of enjoyment as you pedal through the streets. I know that feeling and its a great one. I am just baffled how loud it must be in person, if you pulled up next to me I honestly think I wouldn't be able to tell if you had a v8 or v6. Definitely one of the most beefiest ohv's I have ever heard.

ITS LOUD!!!too loud,ten years ago i would have loved it but now of days its just too loud.its way better with the pass side windows up but you can still hear it clear as day with all of them up.full blown motor heads swear its a v8;) i only hit 7lbs of boost in that video and i eased of the throttle way early in first,you can see it shift at like barly above 5k.i didnt want to just get right out of it,think thqt would have drawn even more attention .i passed the cop right at about 4800 rpms first gear,he followed me all the way home but didnt pull me over;)
 


Join the Elite Explorers for $20 per year. Gets rid of the ads! New $5 per month "try out" option.

Elite Explorer members see no advertisements, no banner ads, no double underlined links, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create and save more private conversations, and more. Join Today. Your support is greatly appreciated.




jd4242

Elite Explorer
Joined
October 15, 2008
Messages
10,788
Reaction score
286
City, State
va beach
Year, Model & Trim Level
92explorer&94 ranger
ok back on subject,some been asking for drive by or inside sound clips.well here is a quick one and your understand why i want to go to a quieter muffler,thinking a 50 series.i need a real camera,phone doesnt seem to rec low tones


Ill do another with the pass side windows up soon and maybe ill get to stay in it this time!
 




phix-

Well-Known Member
Joined
October 17, 2011
Messages
205
Reaction score
0
Year, Model & Trim Level
96.5
We both run all stock pullies,i have a smallere pulley on my alternator tho

Yea.. I run no stock idler and switched to the one that is part of the blower setup. Speaking of alternators I have another new one from Mr. Alternator as the first one has an idle down issue. Hope to swap it out this weekend and try cleaning my engine bay.
 




Dono

347 V8 Limited turbo
Elite Explorer
Joined
February 18, 2009
Messages
5,306
Reaction score
579
City, State
Winnipeg, Manitoba
Year, Model & Trim Level
00 Limited V8
Strange issue Phix. My gatorback is still working ok, and I do have an allignment issue.
I drove out to the lake (About 4 hour round trip) for a night of poker, and fishing. No issue to report.

I did try shimming my pulley out, but that was a bad idea. The shaft is tapered for an interference fit (I didn't notice, and should have). All I did was trash my aluminum 2.7" pulley. The only real fix I have is to pull the M90 mount off and drill some new holes about 1/4 inch forward.
 




Dono

347 V8 Limited turbo
Elite Explorer
Joined
February 18, 2009
Messages
5,306
Reaction score
579
City, State
Winnipeg, Manitoba
Year, Model & Trim Level
00 Limited V8
Ok, to get the green stripe gates belt, all you need to do is add 'HD' to the standard part number you require.
 




jd4242

Elite Explorer
Joined
October 15, 2008
Messages
10,788
Reaction score
286
City, State
va beach
Year, Model & Trim Level
92explorer&94 ranger
Ok, to get the green stripe gates belt, all you need to do is add 'HD' to the standard part number you require.

Or "br" for the blue racing.i listed all three belts for your truck on the other page.
 




jd4242

Elite Explorer
Joined
October 15, 2008
Messages
10,788
Reaction score
286
City, State
va beach
Year, Model & Trim Level
92explorer&94 ranger
YOUR BELT IN BLUE
K061054RB RACING MICRO-V
http://www.gatespowerpro.com/Comerg...tNavigateFrame&CFID=51624348&CFTOKEN=14397452

still looking for green

i believe this is the green
K061058HD FLEETRUNNER MICRO-V

first two numbers is amount of ribs (06),the next 4 is the size (105.8) works the same for most belts

Exactly. I found a cross reference for belts.
http://crossbelts.com/serpentine/6ribkseries.html
It doesn't have belt length in the chart, unfortunately.

So, My belt is 105.5" long. Gatorback #is 6PK2680, so Gates would be K061058
I think the Gatorback rates right up there with the Gates belts though. Phix, you using the same sized belt as me?
 




Dono

347 V8 Limited turbo
Elite Explorer
Joined
February 18, 2009
Messages
5,306
Reaction score
579
City, State
Winnipeg, Manitoba
Year, Model & Trim Level
00 Limited V8
Sorry, don't know how I missed it.
 




jd4242

Elite Explorer
Joined
October 15, 2008
Messages
10,788
Reaction score
286
City, State
va beach
Year, Model & Trim Level
92explorer&94 ranger
Sorry, don't know how I missed it.

Lol all good.was trying to save you some time;)i might just end up with both greens.i can find the blue but belts will be different sizes once i add this other pulley.
 




Dono

347 V8 Limited turbo
Elite Explorer
Joined
February 18, 2009
Messages
5,306
Reaction score
579
City, State
Winnipeg, Manitoba
Year, Model & Trim Level
00 Limited V8
I just ordered a green belt. Amazon had them. After $16.00 in shipping, it was $50.00
 




jd4242

Elite Explorer
Joined
October 15, 2008
Messages
10,788
Reaction score
286
City, State
va beach
Year, Model & Trim Level
92explorer&94 ranger
well its not so purdy any more.really need to figure out where water is getting into:banghead:the plugs is not the cause of the problem.o and ive been seeing the highest temps ever this last couple trips,hit like 153 after charger and 133 before,but its been over a 100+ outside
ps gota love my beer bucket splash guard...hey it works;)
2012-06-30144013.jpg

2012-06-29193858.jpg
 




Dono

347 V8 Limited turbo
Elite Explorer
Joined
February 18, 2009
Messages
5,306
Reaction score
579
City, State
Winnipeg, Manitoba
Year, Model & Trim Level
00 Limited V8
Love the splash guard. Nothing like improvising with stuff thats laying around. 4 wheeling more fun now?

When water gets on the motor, does the spark plug porcelain crack all the time? What plug # fouls? I doubt I'll have an answer for you, but sometimes working thru something can help you find the answer.
 




jd4242

Elite Explorer
Joined
October 15, 2008
Messages
10,788
Reaction score
286
City, State
va beach
Year, Model & Trim Level
92explorer&94 ranger
Love the splash guard. Nothing like improvising with stuff thats laying around. 4 wheeling more fun now?

When water gets on the motor, does the spark plug porcelain crack all the time? What plug # fouls? I doubt I'll have an answer for you, but sometimes working thru something can help you find the answer.

It would be if it could keep running right:(the porcelain cracking i think was just a random thing but the fouling of plugs is a result of the loss of spark.theses are nonprotruding tip race plugs so they will foul very easy.i cant figure out where this water is getting.i was the motor again the other day and dried every thing,took every connector apart and made sure it was dry and applied anticsorrosion/water proof gel to everything and it still ran like shit for 6hours,then back to normal:(this weekend im going to start it and apply water directly to a area at a time till it starts to run like crap !! i also now have a bad rear axle seal,gear oil is leaking onto my tire:(besides that she is still running strong as can be minus belt slip!
 




jd4242

Elite Explorer
Joined
October 15, 2008
Messages
10,788
Reaction score
286
City, State
va beach
Year, Model & Trim Level
92explorer&94 ranger
O and for the record I've had this water problem before the supercharger was installed :(
 




Dono

347 V8 Limited turbo
Elite Explorer
Joined
February 18, 2009
Messages
5,306
Reaction score
579
City, State
Winnipeg, Manitoba
Year, Model & Trim Level
00 Limited V8
I would think it wouldn't be a new issue.
Strange, as you have done everything first class the whole way.

Do you know which plug constantly fouls? Hopefully your plan this weekend works. At least if you already have the time set aside for troubleshooting you will be able to narrow down the issue.

I guess you can't exactly check the codes and see which cylinder is giving the issue.

Coil pack getting water in it? That would make 2 cylinders misbehave though.
 




jd4242

Elite Explorer
Joined
October 15, 2008
Messages
10,788
Reaction score
286
City, State
va beach
Year, Model & Trim Level
92explorer&94 ranger
I would think it wouldn't be a new issue.
Strange, as you have done everything first class the whole way.

Do you know which plug constantly fouls? Hopefully your plan this weekend works. At least if you already have the time set aside for troubleshooting you will be able to narrow down the issue.

I guess you can't exactly check the codes and see which cylinder is giving the issue.

Coil pack getting water in it? That would make 2 cylinders misbehave though.

Its random,they don't all ways foul,give it about 6 hours and it runs fine again.the plug that normally fouled out is the same plug i think i have a bad valve seal in.its the valve that the rocker blew up in years ago and i think it damaged the seal,not really related.when i get water on whatever im not certain its just one cylinder .its complete loss of power and sounds like the timing or spark is way off or running out gas but will idle,can really only tell when under load.know its not gas issue tho.its ignition related.i don't think its the coil,its pretty new and I've sprayed/misted the coil and wires to look for sparks of arcs and saw none.hopefully i find it this weekend:(
 




jd4242

Elite Explorer
Joined
October 15, 2008
Messages
10,788
Reaction score
286
City, State
va beach
Year, Model & Trim Level
92explorer&94 ranger
Well i was going to make my own belt slip pulley but came across this.it looks like it will work better and give more grip.my charger sits at a angle too so the belt slip pulley will be even more under it,more wrap.now to find this water crap!!
http://www.wbodystore.com/pulleys-belts/113-belt-wrap-kit.html
IMAG0597.jpg
 








jd4242

Elite Explorer
Joined
October 15, 2008
Messages
10,788
Reaction score
286
City, State
va beach
Year, Model & Trim Level
92explorer&94 ranger
Good luck with the water issue, ive been chasing that since i bought mine

I've only had it sense last year.we was on a trip and i did a water crossing and shut it off because i thought i sucked water in bet the filter was dry and every time i washed the motor from then on it would do it:(oooo i will find it believe me..im on a mission ,got ten grand under the hood and it needs to work ALL the time!!!:mad:
 


Join the Elite Explorers for $20 per year. Gets rid of the ads! New $5 per month "try out" option.

Elite Explorer members see no advertisements, no banner ads, no double underlined links, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create and save more private conversations, and more. Join Today. Your support is greatly appreciated.




rickybobby

Explorer Addict
Joined
June 26, 2010
Messages
1,252
Reaction score
3
City, State
Battle Creek, mi
Year, Model & Trim Level
'97 XLT
it is a bit funny, mine started like that too, but the filter was wet. I dont think it actually sucked water though, cause it fired right up once i pulled the air box above water level, and i know it isnt water damage to the MAF because i replaced it after that. I have also put over 40k on the engine since too, so that almost completely eliminates a hydrolock, usually even if they start after there is bearing damage
 




Top