• Register Today It's free! This box and some ads will disappear once registered!

^^Searches ExplorerForum.com^^

MFT Black / Blank Screen

peterk9

Staff member
Moderator
Elite Explorer
Joined
December 28, 2010
Messages
26,472
Reaction score
1,386
City, State
Ottawa, Ontario area
Year, Model & Trim Level
2020 Aviator Reserve II
Callsign
VE3
I will try Voltmeter Friday morning
(Raining in SWFL today/tonight)
Nav. Screen dark about 1 week after purchase.
Sad part in SW Florida all dealers are booked for at least 3 weeks.
(Maybe our last Ford Product)
Called other dealers and NOT one called me back after they said they would.
Using the steering wheel cursor the dash display says Audio off and we cannot change it to any other setting , including the radio on/off button.
When I got that battery saver notification, I could not turn the radio on but everything did come back to life when I started the vehicle. It sounds like yours isn't. So while your battery may be low, the other possibility is a faulty APIM, Accessory Protocol Interface Module which is the 'brains' of the MFT. There are a few threads on that that you can find with the 'Search' function.
The APIM is located under the dash. Ford has extended the warranty on it to 5 years due to all the issues they were having with it.
BTW, it would be helpful if you added the trim level (Platinum) to your profile so it shows in the margin at all times.
I also merged your thread with this existing one for now.

Peter
 
Join the Elite Explorers for $20.

Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no advertisements, no banner ads, no double underlined links, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create and save more private Conversations, and more. Join Today. Your support is greatly appreciated.


Ford Explorer Fl

New Member
Joined
January 14, 2016
Messages
13
Reaction score
2
Year, Model & Trim Level
2016 Explorer Platinum
Measured Battery Voltage today

Measured Battery Voltage today

First thing in morning after car was off for 16 hours.
12.5 volts dc

Car Running
14.3 Volts Dc

after starting car
Display says "Powering down to save battery"

CD eject button works and screen says "NO Disc"
Load CD and Screen says " Reading disc"
Lower left corner " Entertainment " Beeps when touching screen"

then screen goes blank.
 

peterk9

Staff member
Moderator
Elite Explorer
Joined
December 28, 2010
Messages
26,472
Reaction score
1,386
City, State
Ottawa, Ontario area
Year, Model & Trim Level
2020 Aviator Reserve II
Callsign
VE3
Measured Battery Voltage today

First thing in morning after car was off for 16 hours.
12.5 volts dc

Car Running
14.3 Volts Dc

after starting car
Display says "Powering down to save battery"

CD eject button works and screen says "NO Disc"
Load CD and Screen says " Reading disc"
Lower left corner " Entertainment " Beeps when touching screen"

then screen goes blank.
Try and see if another dealer can get you in earlier.

Peter
 

sheltonfilms

Active Member
Joined
June 9, 2010
Messages
899
Reaction score
62
City, State
Hoover, AL
Year, Model & Trim Level
2013 Limited 3.5L
Measured Battery Voltage today

First thing in morning after car was off for 16 hours.
12.5 volts dc

Car Running
14.3 Volts Dc

after starting car
Display says "Powering down to save battery"

CD eject button works and screen says "NO Disc"
Load CD and Screen says " Reading disc"
Lower left corner " Entertainment " Beeps when touching screen"

then screen goes blank.
I did a little research and a lot of people are saying bad battery cell.

I've also seen others say they have USB and 12V accessories connected and it causes it. If you have anything like an ipod/iphone cable or phone charger. Please disconnect and see if this helps.
 

Ford Explorer Fl

New Member
Joined
January 14, 2016
Messages
13
Reaction score
2
Year, Model & Trim Level
2016 Explorer Platinum
I did a little research and a lot of people are saying bad battery cell.

I've also seen others say they have USB and 12V accessories connected and it causes it. If you have anything like an ipod/iphone cable or phone charger. Please disconnect and see if this helps.
No electronics plugged in to any ports.

Looks like I will have to wait another 17 days for service, not much else we can do. all other Ford dealers are busy in SWFL

Checked each battery cell and they are all 2.2 volts each
 

jmr061

Well-Known Member
Joined
August 24, 2014
Messages
1,823
Reaction score
117
City, State
Wisconsin
Year, Model & Trim Level
16 Edge
Pr-16 Exp Sport
Have you disconnected the battery....let it sit for a minute and reconnected it?
 

Ford Explorer Fl

New Member
Joined
January 14, 2016
Messages
13
Reaction score
2
Year, Model & Trim Level
2016 Explorer Platinum
Have you disconnected the battery....let it sit for a minute and reconnected it?
worked fine for my wife last night, but dead today.
Only 16 days to earliest appointment available in Southwest Florida.
 

Robert Lau

New Member
Joined
August 12, 2016
Messages
3
Reaction score
0
City, State
kailua
Year, Model & Trim Level
2012 Ford Explorer
Hi all,
New to this forum and have had my Explorer for about 4 years. Love it, great car and my wife loves it. Happy wife, happy life right. Great experiences thus far until we need to get it fixed. Bought all the extended warranties and maintenance plan and had all the services done regularly. Then reality strikes when you need something fixed.
I won't mention my other horrible experiences with the local dealer but rather talk about the current one Im dealing with. We got the black screen of death last Wednesday when phone bluetooth, radio and Sync screen went. So i called the dealer and spoke with one of the lead mechanics and he couldn't figure out what the problem could be. Then he said he would leave a message with the service desk and the service manager to call me back the next day. I got no calls. So 3 days later I said, maybe I should call and so I did. I talked about the symptoms of the issue and also brought up the issue about the replacement ACM they told me takes 2-3 weeks to come in they were supposed to replace. 3 months later, no part yet, anyway, he needed to check on the part and ask about what the problem with the black screen so he would call me back the next day. Well, he didn't, so i called on Saturday to follow-up, he said parts dept had the ACM(idk why no one called me) and that I needed to bring the car in to check out the black screen. So I made an appt for yesterday. Took the car in early morning and they would replace the ACM(they called it an amp) and troubleshoot black screen. So, i called yesterday for the status of the repair. They said they replaced the ACM(how do you know it works with the black screen and no radio) and are doing circuit testing for the black screen, and will need the car to stay overnight to be looked at tomorrow. I told them my wife needs the car Friday afternoon so they need to be done, call me when it's ready. Soooo, i call in today(Friday) at 1:30 to find out the status. I spoke with service manager because Im already fuming, he said he would check and call me back.. Hurray, he called me back 10 minutes later. He said, they discovered it's the APIM and that they need to get the ES number off of the APIM but it's read through the screen(which is not working) so they'll have to wait till Monday to call the mainland(continental US) for further steps in troubleshooting the issue and if there's further information they need, he'll call me. So by now, I'm headed to pick up my car and I talked to the service desk. Attendant tells me when I can I bring the car back. I tell her, don't you have to call to find out further steps?? She said, "hold on, let me check with service manager". She comes back and tells me that they completed the first step which is call the mainland and troubleshoot the issue. So they determined it was the APIM. Second step is they needed the serial number off the APIM so they can order the right part and Ford can approve it. Mind you my car was there for almost 2 days. So finally I said, "you mean to tell me that after my car was here for almost 2 days, i need to bring it back so you can get the serial number of the part that needs to be replaced? Also, I'll need to bring my car back again when the part comes in to get it replaced?" She said yes
So I get home and log into My Ford and enter my VIN, Audio Accessory Interface Module $650.67.
You know, my wife has had Fords for 20+ years and have been going to the same dealer that long as well and receiving excellent service until they were sold. Everything went downhill from that point on.
We purchase these warranties and maintenance plans in hopes that our investment is working when we need them to and reliably. If this is the kind of service I'm going to get for paying thousands more for, I think I would buy something else but a Ford.
Anyone with any suggestions???
 
Last edited:

Robert Lau

New Member
Joined
August 12, 2016
Messages
3
Reaction score
0
City, State
kailua
Year, Model & Trim Level
2012 Ford Explorer
anyone with similar issues? especially with the APIM? Is it normal protocol these days to bring your car in, troubleshoot the issue, have them order the part, and come back again to install? Or does most dealers carry spare parts. I know there are parts depts out there
 

FordIVTteam

Official Ford Rep
Joined
July 13, 2011
Messages
1,690
Reaction score
1
City, State
Dearborn, MI
Year, Model & Trim Level
Ford Explorer
Hey Robert Lau,

The replacement of the APIM usually takes less than one day. The dealer may require more time due to parts on hand and scheduling requirements. The APIM is the brains of SYNC and is not always accessible as a spare part.

Shaay
 

Robert Lau

New Member
Joined
August 12, 2016
Messages
3
Reaction score
0
City, State
kailua
Year, Model & Trim Level
2012 Ford Explorer
Thanks Shaay,
what i didn't get is that they had replaced my ACM and while doing that, why didn't they just get the serial number of the APIM at that time. Instead my car was there for 2 days and when i got my car back, they said I needed to bring it in again so they can just get the serial number of the APIM.
 

peterk9

Staff member
Moderator
Elite Explorer
Joined
December 28, 2010
Messages
26,472
Reaction score
1,386
City, State
Ottawa, Ontario area
Year, Model & Trim Level
2020 Aviator Reserve II
Callsign
VE3
Thanks Shaay,
what i didn't get is that they had replaced my ACM and while doing that, why didn't they just get the serial number of the APIM at that time. Instead my car was there for 2 days and when i got my car back, they said I needed to bring it in again so they can just get the serial number of the APIM.
The APIM has a 5 year unlimited mileage warranty on it. It was extended due to all the problems owners of the early year models were having with them.

Peter
 

FordIVTteam

Official Ford Rep
Joined
July 13, 2011
Messages
1,690
Reaction score
1
City, State
Dearborn, MI
Year, Model & Trim Level
Ford Explorer
Thanks Shaay,
what i didn't get is that they had replaced my ACM and while doing that, why didn't they just get the serial number of the APIM at that time. Instead my car was there for 2 days and when i got my car back, they said I needed to bring it in again so they can just get the serial number of the APIM.
You're welcome, Robert Lau. I understand how that can be concerning. Let's hope everything goes great from now on. Keep me posted!

Shaay
 

dmuscat

New Member
Joined
October 9, 2015
Messages
13
Reaction score
0
City, State
Michigan
Year, Model & Trim Level
2015 Ford Explorer LTD
One issue that went away for me in my corrective actions was that I had always left a USB stick in the USB slot in the car. The USB stick had music and finding out that the USB stick was too large (16GB) and the wrong format (NTFS should be FAT), once I learned from the IVT team that MFT has issues with leaving USB sticks in for long period of time will cause issues with MFT. when I pulled my USB stick out and processed a reset 6months ago, all my black screen issues went away and most of all my other weird MFT issues went away. Seems that an improperly formatted USB stick and the wrong size USB stick causes issues with MFT along with leaving a USB stick in the USB slot for long periods of time.
 

mikeol

New Member
Joined
January 23, 2017
Messages
2
Reaction score
0
Year, Model & Trim Level
2016, Explorer XLT
I purchased a 2016 explorer about 6 months ago. I'm am very unhappy with the touchscreen, it's difficult to press, laggy, and three times now it has randomly blacked out on my and didn't turn back on until I turned the car off / on.
 

peterk9

Staff member
Moderator
Elite Explorer
Joined
December 28, 2010
Messages
26,472
Reaction score
1,386
City, State
Ottawa, Ontario area
Year, Model & Trim Level
2020 Aviator Reserve II
Callsign
VE3
I purchased a 2016 explorer about 6 months ago. I'm am very unhappy with the touchscreen, it's difficult to press, laggy, and three times now it has randomly blacked out on my and didn't turn back on until I turned the car off / on.
Welcome to the Forum.:wave:
Have you verified that your software is up to date with version 3.8?
Press Settings on the MFT screen, then press Help and then press System Information. Then you will see CCPU S/W Version. It should show 3.08.15128.EA.10_PRODUCT.
If you have that version then the problem could be with the APIM (Accessory Protocol Interface Module) which is the 'brains' of the MFT system. Best to have the dealer look at it.
Good luck.

Peter
 

mikeol

New Member
Joined
January 23, 2017
Messages
2
Reaction score
0
Year, Model & Trim Level
2016, Explorer XLT
Thanks for your reply, I will check it out tomorrow. I feel there must be some issue with it, unless the touch screen is usually unresponsive (I'm use to a smartphone the touchscreen in my explorer operates more like an ATM.) But, the blackout thing must be an issue.
 

goodmank

New Member
Joined
December 29, 2015
Messages
5
Reaction score
0
City, State
North, VA
Year, Model & Trim Level
2012 Ford Explorer LTD
So my wife and I have a 2012 Ford Explorer 4WD Limited and we just started getting the Black Screen of Death. After reading this thread just found out that the APIM is probably 99% the issue and that Ford extended the warranty to 5 years unlimited mileage. Unfortunately, 5 years was up 2/20/17 and obviously today is 04/19/17. Is there anything we can do? I don't have $1000 to throw at a new APIM and it controls the backup camera and the navigation as well as any music at all. I have already spent a lot of money at Wynne Ford and Bowditch Ford replacing a ton of other parts and maintenance. Any help would be sincerely appreciated!!!
 
Last edited:

peterk9

Staff member
Moderator
Elite Explorer
Joined
December 28, 2010
Messages
26,472
Reaction score
1,386
City, State
Ottawa, Ontario area
Year, Model & Trim Level
2020 Aviator Reserve II
Callsign
VE3
So my wife and I have a 2012 Ford Explorer 4WD Limited and we just started getting the Black Screen of Death. After reading this thread just found out that the APIM is probably 99% the issue and that Ford extended the warranty to 5 years unlimited mileage. Unfortunately, 5 years was up 2/20/17 and obviously today is 04/19/17. Is there anything we can do? I don't have $1000 to throw at a new APIM and it controls the backup camera and the navigation as well as any music at all. I have already spent a lot of money at Wynne Ford and Bowditch Ford replacing a ton of other parts and maintenance. Any help would be sincerely appreciated!!!
Have you spoken to either dealer about this issue to see what if anything they can do to help out?

Peter
 
Join the Elite Explorers for $20.

Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no advertisements, no banner ads, no double underlined links, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create and save more private Conversations, and more. Join Today. Your support is greatly appreciated.


goodmank

New Member
Joined
December 29, 2015
Messages
5
Reaction score
0
City, State
North, VA
Year, Model & Trim Level
2012 Ford Explorer LTD
I spoke to Wynne Ford who I have done a lot of business with and the service person told me there is nothing they can do because it is 2 months past when the extended warranty expired. Is there anyone on here that has any way of contacting someone higher on the Ford totem pole to possibly get some help with the cost?
 

Top