Sync 3.4 Update 21020 and OTA Updates | Page 13 | Ford Explorer - Ford Ranger Forums - Serious Explorations

  • Register Today It's free! This box and some ads will disappear once registered!

Sync 3.4 Update 21020 and OTA Updates

Dale5403

Well-Known Member
Joined
February 18, 2020
Messages
537
Reaction score
131
City, State
Mondovi, WI
Year, Model & Trim Level
2020 Explorer ST
Ford has said that this is a known issue but I don't believe enough complaints have been raised for them to do anything to correct it quickly. I would go to your dealership to do so. The only known fix is to downgrade to version 20282 which my dealership said they have no way of doing. If you do downgrade make sure you do a Master Reset after then turn off WIFI and auto update. Mine has been working fine for about a week since I did it.
Well after mine downloaded 21020 Travel Link was working for 3 or 4 days. Then today it stopped once again. Even lost the audio once. So I plan to take it back in for service and see what happens. Figure the more that go in for service the better the chance of Ford coming up with a solution. I can always roll it back to 20282 if need be.
 


Join the Elite Explorers for $20 per year. Gets rid of the ads! New $5 per month "try out" option.

Elite Explorer members see no advertisements, no banner ads, no double underlined links, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create and save more private conversations, and more. Join Today. Your support is greatly appreciated.




rlh6805

Member
Joined
June 13, 2021
Messages
43
Reaction score
13
City, State
Gaylord
Year, Model & Trim Level
2021 Expedition
Does anyone know what sw version TSB 21-2150 changes the system to?
 

Attachments

  • TSB 21-2150.pdf
    1.4 MB · Views: 28




rlh6805

Member
Joined
June 13, 2021
Messages
43
Reaction score
13
City, State
Gaylord
Year, Model & Trim Level
2021 Expedition
Well after mine downloaded 21020 Travel Link was working for 3 or 4 days. Then today it stopped once again. Even lost the audio once. So I plan to take it back in for service and see what happens. Figure the more that go in for service the better the chance of Ford coming up with a solution. I can always roll it back to 20282 if need be.
That's what happened to me. For sure TL worked after the 21020 update for some time. I don't really look at it very much and my wife drives the vehicle more than I.
 








peterk9

Staff member
Moderator
Elite Explorer
Joined
December 28, 2010
Messages
31,606
Reaction score
2,436
City, State
Russell, Ontario (Ottawa area)
Year, Model & Trim Level
2020 Aviator Reserve
Callsign
VE3
Does anyone know what sw version TSB 21-2150 changes the system to?
It mentions updating to the latest software version which in this case would be 21020.

Peter
 




rlh6805

Member
Joined
June 13, 2021
Messages
43
Reaction score
13
City, State
Gaylord
Year, Model & Trim Level
2021 Expedition
When I had mine in for that TSB there was no change made to the software. It remained at 21020

It mentions updating to the latest software version which in this case would be 21020.

Peter

Well that would make no sense since the issue is with ver 21020. I am reading on other forums that the TSB installs ver 20136 but retains the NAV NA 2 20.

Ford really screwed the pooch with Sync 3. I have a new RAM 2500 too (with the 12" screen) and Uconnect blows Sync away. I really hope Sync 4 is better.
 




Dale5403

Well-Known Member
Joined
February 18, 2020
Messages
537
Reaction score
131
City, State
Mondovi, WI
Year, Model & Trim Level
2020 Explorer ST
Well that would make no sense since the issue is with ver 21020. I am reading on other forums that the TSB installs ver 20136 but retains the NAV NA 2 20.

Ford really screwed the pooch with Sync 3. I have a new RAM 2500 too (with the 12" screen) and Uconnect blows Sync away. I really hope Sync 4 is better.
I wouldn't want to go back to 20136. Version 20282 is newer and it worked fine for me. If I roll back again that is the version I will be using.
 




Ken St John

Active Member
Joined
July 16, 2019
Messages
54
Reaction score
29
Location
Tacoma, WA
City, State
WA
Year, Model & Trim Level
2020 Explorer ST
When I had mine in for that TSB there was no change made to the software. It remained at 21020
When my dealer ran that one, it went back to 20136. Ran rough and gave me a lot of weird indications, but it ran. But, they left the wifi/auto updates on (and I didn't check) and after a couple of days, 21020 showed up, along with all of the issues. I manually rolled back to 20282 but this time ensured that wifi/autoupdate are both OFF. Maps remained at NA 2.20. 20282 seems to run OK, if a little but slower than before this whole mess started.

I've had in car navs from Jaguar, Saab, Ram and SYNC 2 & 3 from Ford in previous cars. NEVER had a mess like this before. My previous Sync updates are seemed to work well and improved performance in places that were noticeable. But, clearly this one (21020) is really buggy and should NOT have been released without more testing!!

I expect Ford to fix it in a release sooner rather than later ... although I doubt you'll ever hear them say "Oops" or "Sorry"!!

Ken
 




mikegrad77

Active Member
Joined
April 16, 2019
Messages
96
Reaction score
43
City, State
Westchester NY
Year, Model & Trim Level
2020 ST Atlas Blue
well, i guess u should have come here before installing any updates! I just did a USB install on saturday. I havent noticed any issues - but i dont use the nav or the traffic links, or anything like that.

has anyone posted a g-drive link or something to the previous version? I hate it - i just deleted it off the USB i used to upgrade. grrrr.:mad:
 




rlh6805

Member
Joined
June 13, 2021
Messages
43
Reaction score
13
City, State
Gaylord
Year, Model & Trim Level
2021 Expedition
When my dealer ran that one, it went back to 20136. Ran rough and gave me a lot of weird indications, but it ran. But, they left the wifi/auto updates on (and I didn't check) and after a couple of days, 21020 showed up, along with all of the issues. I manually rolled back to 20282 but this time ensured that wifi/autoupdate are both OFF. Maps remained at NA 2.20. 20282 seems to run OK, if a little but slower than before this whole mess started.

I've had in car navs from Jaguar, Saab, Ram and SYNC 2 & 3 from Ford in previous cars. NEVER had a mess like this before. My previous Sync updates are seemed to work well and improved performance in places that were noticeable. But, clearly this one (21020) is really buggy and should NOT have been released without more testing!!

I expect Ford to fix it in a release sooner rather than later ... although I doubt you'll ever hear them say "Oops" or "Sorry"!!

Ken
Lets hope so. I'm willing to leave it be for now rather that mess with it IF I knew an update was coming to fix the issue soon.
Is there a phone number to call for Ford Sync support that maybe I could call and ask?
 




peterk9

Staff member
Moderator
Elite Explorer
Joined
December 28, 2010
Messages
31,606
Reaction score
2,436
City, State
Russell, Ontario (Ottawa area)
Year, Model & Trim Level
2020 Aviator Reserve
Callsign
VE3
well, i guess u should have come here before installing any updates! I just did a USB install on saturday. I havent noticed any issues - but i dont use the nav or the traffic links, or anything like that.

has anyone posted a g-drive link or something to the previous version? I hate it - i just deleted it off the USB i used to upgrade. grrrr.:mad:
Hi Mike. Do all the Travel Link features show "subscribed" when you are driving? Mine takes about 30 seconds or so to show "subscribed" after each key cycle. How about the map version. Is it 2.20?

Peter
 




Dale5403

Well-Known Member
Joined
February 18, 2020
Messages
537
Reaction score
131
City, State
Mondovi, WI
Year, Model & Trim Level
2020 Explorer ST
Lets hope so. I'm willing to leave it be for now rather that mess with it IF I knew an update was coming to fix the issue soon.
Is there a phone number to call for Ford Sync support that maybe I could call and ask?
(800) 392-3673 is the number I called and they opened a case number from there. Still working to get it resolved and I have an appointment Thursday of next week.
 




mikegrad77

Active Member
Joined
April 16, 2019
Messages
96
Reaction score
43
City, State
Westchester NY
Year, Model & Trim Level
2020 ST Atlas Blue
Hi Mike. Do all the Travel Link features show "subscribed" when you are driving? Mine takes about 30 seconds or so to show "subscribed" after each key cycle. How about the map version. Is it 2.20?

Peter
Hi peter, it took me some time to find the location for travel link features because i dont use them. by the time i did they showed subscribed. I shut down and restarted and they showed subscribed right away.

map version is NA 118, Sync build 21020
 




rlh6805

Member
Joined
June 13, 2021
Messages
43
Reaction score
13
City, State
Gaylord
Year, Model & Trim Level
2021 Expedition
Hi peter, it took me some time to find the location for travel link features because i dont use them. by the time i did they showed subscribed. I shut down and restarted and they showed subscribed right away.

map version is NA 118, Sync build 21020
So is the problem with the maps? Because with 21020 and map ver 2 20 Travel Link is broken.
 




Dale5403

Well-Known Member
Joined
February 18, 2020
Messages
537
Reaction score
131
City, State
Mondovi, WI
Year, Model & Trim Level
2020 Explorer ST
So is the problem with the maps? Because with 21020 and map ver 2 20 Travel Link is broken.
I don't think the map is the issue. When I rolled mine back to 20282 with the map at 220 it ran fine. With Sync back at 21020 again it's not working.
 




peterk9

Staff member
Moderator
Elite Explorer
Joined
December 28, 2010
Messages
31,606
Reaction score
2,436
City, State
Russell, Ontario (Ottawa area)
Year, Model & Trim Level
2020 Aviator Reserve
Callsign
VE3
Hi peter, it took me some time to find the location for travel link features because i dont use them. by the time i did they showed subscribed. I shut down and restarted and they showed subscribed right away.

map version is NA 118, Sync build 21020
If you are connected to a WiFi source, the maps will probably begin downloading automatically. There are many files and it takes a lot of time.

Peter
 




rlh6805

Member
Joined
June 13, 2021
Messages
43
Reaction score
13
City, State
Gaylord
Year, Model & Trim Level
2021 Expedition
I don't think the map is the issue. When I rolled mine back to 20282 with the map at 220 it ran fine. With Sync back at 21020 again it's not working.
Right, doesn't seem like it would be if the same map db is being used.
 




Sgt1411

Elite Explorer
Joined
February 22, 2011
Messages
4,443
Reaction score
401
City, State
VanBC/GoodyearAZ
Year, Model & Trim Level
2021 Explorer ST
Callsign
PRINCE51
All my SiriusXM Travel Link and Traffic subscriptions came back today, I will keep monitoring but I did NOT rollback from 21020.

Traffic seems to load quicker now as well.
 




Will3

Well-Known Member
Joined
July 17, 2019
Messages
107
Reaction score
20
Year, Model & Trim Level
2020 Explorer ST
All my SiriusXM Travel Link and Traffic subscriptions came back today, I will keep monitoring but I did NOT rollback from 21020.

Traffic seems to load quicker now as well.
Same for me when I was out and about Last Friday and Saturday. As I said in previous post, I’m sticking with 21020, and watching for an update from Ford.
 


Join the Elite Explorers for $20 per year. Gets rid of the ads! New $5 per month "try out" option.

Elite Explorer members see no advertisements, no banner ads, no double underlined links, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create and save more private conversations, and more. Join Today. Your support is greatly appreciated.




Sgt1411

Elite Explorer
Joined
February 22, 2011
Messages
4,443
Reaction score
401
City, State
VanBC/GoodyearAZ
Year, Model & Trim Level
2021 Explorer ST
Callsign
PRINCE51
Spoke too soon, upon driving today everything except SiriusXM audio is gone.......shows UNSUBSCRIBED........another call to SiriusXM
 




Top